Issues accessing CleverEV

Resolved after 13 hours 7 minutes

This incident has been resolved.

Posted 6 months ago

Monitoring

We're seeing services recover. We'll continue to monitor and provide updates if necessary.

Posted 6 months ago

Investigating

Some users may experience difficulties accessing CleverEV due to an upstream provider outage. Our team is investigating potential mitigations.

Posted 6 months ago

Components impacted: Web Console, Website, API, and Charger Gateway